Gen 1 Xterra turn signals not blinking - Nissan Xterra Forum
 
Thread Tools Display Modes
post #1 of 4 Old 02-17-2013, 06:23 PM Thread Starter
ericm215
Noob
 
Join Date: Feb 2010
Location: Bergen County, New Jersey
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2001 Xterra
ericm215 is on a distinguished road
Gen 1 Xterra turn signals not blinking

Hello everyone, my 2001 xterra's turn signals stopped blinking, when I move the lever on the steering column they are stuck in the on position but do not blink. This happens both with the left and right positions as well as the hazards. Then I turn the car off and back on and they work. Later on after another stop and start of the car they stop working again. Any ideas how troubleshoot this? If it is the relay, where is it located? Thanks in advance for your assistance.
ericm215 is offline  
2001 Xterra
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-18-2013, 11:25 AM
cbxterra
Veteran
 
Join Date: Nov 2010
Location: nova scotia, canada
Posts: 440
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
2000 Xterra
cbxterra is on a distinguished road
Garage
not certain what the problem is but the relay is easy to find. it's up under the dash probably driver's side. just hit the hazards and listen for it clicking in time with the signals [when they are working] good luck
cbxterra is offline  
2000 Xterra
post #3 of 4 Old 02-18-2013, 12:07 PM
ayjay
Veteran
 
Join Date: Apr 2012
Location: Spring TX
Posts: 355
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2000 Xterra
ayjay is on a distinguished road
Also, check fuses, and sometimes the brake switch can affect the blinkers, too on some vehicles. Not sure if that's true in the X.

2000 XE V6 4X4 5speed, AC shackles and UCAs, Bilstein 4600, K&N drop-in, intake mod, AC Idler brace, Yakima kayak rack, Shrockworks Skids, custom sliders, BFG AT/KO 32x11.5x15, custom rear bumper/swingout tire carrier, custom front tube bumper, Lokka'd front Diff.

5 speed
4 WD
3 Pedals
2 Diffs
1 Tcase ... The way it was meant to be.
ayjay is offline  
2000 Xterra
post #4 of 4 Old 02-18-2013, 12:52 PM
kms1990
Addict
 
kms1990's Avatar
 
Join Date: Jul 2012
Location: benbrook tx
Posts: 643
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2000 Xterra
kms1990 is on a distinguished road
could be the flasher as well ( should be under hood in fuse box)

MY BRIGHT AZZ LIGHTS!

MY STEREO BEATS EM ALL!
My Laundry List
LIFT()
MUD TIRES()
DROP IN K&N FILTER(X)
UPGRADE STEREO(X)
RESTORE BUMPERS(X)
HID AND PIAA FOGS(X)
FIX UP HEADLINER()
WINCH()
MUFFLER UPGRADE()
kms1990 is offline  
2000 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off