Help!! Very poor mpg - Page 2 - Nissan Xterra Forum
Reply
 
Thread Tools Display Modes
#11 Old 02-13-2013, 06:19 PM
DieselXterra
Veteran
 
Join Date: Feb 2011
Location: New York/Florida/Costa Rica/California
Posts: 269
2002 Xterra
DieselXterra is on a distinguished road
Quote:
Originally Posted by Gsimpson2G View Post
try disconnecting the battery for a little bit to clear that code out. Drive around for awhile, and see what your MPG are then, and check after a bit of driving and see if the code is back,
Disconnecting battery for a while clars codes?

That is why I love this site!
DieselXterra is offline  
2002 Xterra
Sponsored Links
Advertisement
 
#12 Old 02-13-2013, 07:29 PM
muddy
Member
 
Join Date: May 2011
Location: Vancouver BC Canada EH!?
Posts: 43
2002 Xterra
muddy is on a distinguished road
the knock sensor doesn't trigger the engine light must have another code in the system
muddy is offline  
2002 Xterra
#13 Old 02-13-2013, 07:41 PM
xtacular
Spaz
 
xtacular's Avatar
 
Join Date: May 2010
Location: Washington
Posts: 5,409
2002 Xterra
xtacular is a jewel in the rough xtacular is a jewel in the rough xtacular is a jewel in the rough xtacular is a jewel in the rough
Yeah the knock sensor is not tripping your CEL... there's another code. If it's an O2 sensor or something like that it could be affecting your mileage. I'm lifted 4", steel bumpers, 33s and I am getting 15.5 mpgs around town and much better on the highway at reasonable speed.

2002 Super Black 5 Speed 4x4
Lift/Suspension: AC Shackles and UCAs, Extended Bilsteins, 2" BL
Armor: front ARB Bumper, rear Skid Row bumper with custom tire carrier
Steering: Bandit 4x4 idler arm bushings, AC HD TRAs, Calmini IAB; Moog TREs and 555 centerlink
Wheels/Tires: 33x12.5x15 Goodyear Duratracs, desert runner wheels
Performance: K&N intake, Doug Thorley headers, Magnaflow muffler
Electronics: backup camera, Pioneer head unit, JBL 770w amp, JL Audio 12" W0, rear Sony Xplods
xtacular is offline  
2002 Xterra
#14 Old 02-13-2013, 08:11 PM
M3C.CA
Addict
 
M3C.CA's Avatar
 
Join Date: Jun 2011
Location: Vancouver Island, Canada
Posts: 987
2003 Xterra
M3C.CA will become famous soon enough
Quote:
Originally Posted by xtacular View Post
Yeah the knock sensor is not tripping your CEL... there's another code. If it's an O2 sensor or something like that it could be affecting your mileage. I'm lifted 4", steel bumpers, 33s and I am getting 15.5 mpgs around town and much better on the highway at reasonable speed.
Likewise: ~5" lift, 33x12.5 tires and armored and I get 13-15mpg city driving.

mongrel in the making
BUILD THREAD
M3C.CA is offline  
2003 Xterra
#15 Old 02-13-2013, 09:53 PM
kms1990
Addict
 
kms1990's Avatar
 
Join Date: Jul 2012
Location: benbrook tx
Posts: 643
2000 Xterra
kms1990 is on a distinguished road
stock 2000 3.3l with 156000 miles on er highway tread tires 265/70/15s recent minor tune up (new plugs wires and fuel filter and distributor, due to failure not for tune up, and k&n drop in filter)

and fresh fluids (do not flush the tranny unless you know its been done before or the fluid isnt too dark as doing it after too long on old fluid could mess it up a drain and fill with new tranny filter would be more beneficial

i ran pennzoil hm oil 10w30 because a few leaks i had (recently fixed and changed to castrol gtx syn blend 5w30 and noticed a better response and seems like a lil bump in fuel economy, would use full synthetic but dont have the $)

new shocks and accessory belts done, service records show 105k mile tune up done at 117k so i think my timing belt was done and battery

i get about 15.5-17mpg average (depending on how much highway i drive that tank) but even before i did anything to it when i got it a year ago i was getting 14.8-16.7 (depending on highway driving amount) and one tank when i filled at half i got 21mpg best since was 18.4 on a 50% hwy 50% city and usual is between 15.5 and 17.2ish best thing i can recommend you do for this is REPLACE THE FUEL FILTER AND PCV VALVE! that plays a major role in our trucks mpg and power and dump a bottle of regular lucas (clear bottle brown liquid in it when you do that) may also try the diy seafoam in the diy section i used the brake booster vacuum line, here is a link:http://www.clubxterra.org/forums/showthread.php?t=18963

MY BRIGHT AZZ LIGHTS!

MY STEREO BEATS EM ALL!
My Laundry List
LIFT()
MUD TIRES()
DROP IN K&N FILTER(X)
UPGRADE STEREO(X)
RESTORE BUMPERS(X)
HID AND PIAA FOGS(X)
FIX UP HEADLINER()
WINCH()
MUFFLER UPGRADE()

Last edited by kms1990; 02-13-2013 at 10:02 PM.
kms1990 is offline  
2000 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off