Humming noise from engine - Nissan Xterra Forum
 
Thread Tools Display Modes
post #1 of 1 Old 01-23-2013, 02:54 PM Thread Starter
Gsimpson2G
Seasoned
 
Gsimpson2G's Avatar
 
Join Date: Dec 2012
Location: Maynardville, TN
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2002 Xterra
Gsimpson2G is on a distinguished road
Humming noise from engine

So, my engine when cold, has this loud humming noise. It started a little bit after changing the belts. I checked the tension on the belts, and they all seem good. Any ideas? I am thinking it might be the power steering pump. Noticed it looks to be leaking some, and the resivore is down to almost the Min line.

Gsimpson2G is offline  
2002 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off