2003 XE- Trans issue - Page 2 - Nissan Xterra Forum
Reply
 
Thread Tools Display Modes
post #11 of 13 Old 01-11-2013, 09:50 AM Thread Starter
Malarky3113
Member
 
Join Date: Jan 2013
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 Xterra
Malarky3113 is on a distinguished road
Sounds good. Like I said above, I'm only replacing them if it is beyond saving. But I'll be sure to get both if I do. I'll know more after I work on it a little bit on Sunday.
Malarky3113 is offline  
2003 Xterra
Sponsored Links
Advertisement
 
post #12 of 13 Old 01-17-2013, 12:34 PM Thread Starter
Malarky3113
Member
 
Join Date: Jan 2013
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 Xterra
Malarky3113 is on a distinguished road
Finally was about to work on this a little. Yesterday I did a drain and fill, and went out and got a new battery for it. The battery was beyond saving, and turns out, not the right size one for the truck anyway. After all this the truck started right up and idled nice.

Unfortunately, I was late for something so I didn't have time to test the transmission. I plan to let the truck get to temperature, then with out moving shift the gears back and forth making sure they all engage before I even attempt to drive it. Honestly, It was low on trans fluid and what did come out was UGLY. If I get it moving I'll be doing another drain and fill soon.
Malarky3113 is offline  
2003 Xterra
post #13 of 13 Old 01-21-2013, 12:20 PM Thread Starter
Malarky3113
Member
 
Join Date: Jan 2013
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 Xterra
Malarky3113 is on a distinguished road
Well its gone. The drain and fill did help... me realize that the trans cooler was ruptured. When I first checked the coolant, it looked like it just needed to be changed. After the drain and fill, it was black. Figured that out Friday morning just before jumping in the Jeep to head up to Lake Placid for the weekend.

Half way up there, got a call that someone in the development called complaining about it just sitting there. They said I had the weekend to get rid of it. Made some calls and sold it on. They picked it up early this morning.

It sucks, I planned to just run an external cooler (~$40) and hope for the best, but thanks to people with nothing better to do, I had to punt it. At least I came out ahead.
Malarky3113 is offline  
2003 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off