Rough idle problem - Nissan Xterra Forum
 
Thread Tools Display Modes
#1 Old 01-07-2013, 07:48 PM
proudxterraowner
Addict
 
proudxterraowner's Avatar
 
Join Date: May 2012
Location: Southeast Texas
Posts: 580
2009 S 4x4 Xterra
proudxterraowner is on a distinguished road
Rough idle problem

This may or may have been talked about and when I searched there was a bunch over it but they don't have the same symptoms. About 4 days ago, I went muddin and after, I went to the car wash and sprayed most the mud off and I opened the hood to kind of get some of the mud out of the engine compartment and I didn't spray to hard but after finishing up, I got in and started and instantly it was idling crappy. My thought was that I could have gotten something wet and I will just leave it at my grandparents for maybe two days. I went and got her Sunday evening and cranked her up and it will idle then drop some it feels like its going to die but the rpms are well above 500. In drive and reverse it does it a lot. I know that the spark plugs probably haven't been changed cause for the this year and a half I've had it going from 88k miles to 119k now, I've haven't done em. Could that be it? Or a coil or something? Kinda puzzled.

M'name's Hunter

2009 S 4x4
(X)Step rails and mud flaps removed
(X)K/N drop in
( )All Terrains or MTs
( )2" Lift
( )Fog Lights

Have a blessed day my fellow X'ers!
proudxterraowner is online now  
2009 S 4x4 Xterra
Sponsored Links
Advertisement
 
#2 Old 01-08-2013, 09:15 AM
Itsme
Phreak
 
Itsme's Avatar
 
Join Date: Sep 2010
Location: Oregon
Posts: 3,110
2000 4x4 Xterra
Itsme will become famous soon enough Itsme will become famous soon enough
It is more likely that there spark plug areas are filled with water and that is shorting out the plugs.
Plugs should last 100K miles. Ignition wires don't!
The other thing you need to do is remove the distributor cap and wipe off the inside of it, as spark may be tracking on the inside of the cap. (due to moisture and metalic film on inside of cap)

Itsme
2000 X SE

V6 SE 4X4 5spd Build and 00 Silver auto SE 4X4http://www.clubxterra.org/forums/showthread.php?t=26084

Raise TBs (X), paint plastics (X), Replace radiator with one that is bigger and will last (X), install roof lights (X), IAB (X), better tires (X), shackles in rear(X), remove rear sway bar (X), Bilsteins (X)
Itsme is offline  
2000 4x4 Xterra
#3 Old 01-08-2013, 03:13 PM
proudxterraowner
Addict
 
proudxterraowner's Avatar
 
Join Date: May 2012
Location: Southeast Texas
Posts: 580
2009 S 4x4 Xterra
proudxterraowner is on a distinguished road
Thanks man! I'll get to it

M'name's Hunter

2009 S 4x4
(X)Step rails and mud flaps removed
(X)K/N drop in
( )All Terrains or MTs
( )2" Lift
( )Fog Lights

Have a blessed day my fellow X'ers!
proudxterraowner is online now  
2009 S 4x4 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off