2000 Nissan Xterra Stalling and Jerking - Nissan Xterra Forum
Reply
 
Thread Tools Display Modes
#1 Old 01-02-2013, 02:31 PM
estarguars
Member
 
Join Date: Jan 2013
Posts: 10
200 Xterra
estarguars is on a distinguished road
2000 Nissan Xterra Stalling and Jerking

Ill try to make this short and sweet.

X began jerking on the highway and eventually would stall while running. My friend ran the computer and mentioned the ignition coil was failing. Ended up buying the whole distributor, wires and plugs.

After installing the X would run okay but wouldn't hold an idle. It basically stalls each time i let the gas go. Friend suggested the M.A.F sensor, bought installed and still the same.

$600 deep and the X keeps stalling. Timing belt was changed around 105k, currently has round 115k.

I am extremely frustrated, any suggestions?
estarguars is offline  
200 Xterra
Sponsored Links
Advertisement
 
#2 Old 01-02-2013, 05:25 PM
RacerXXL
Administrator
 
RacerXXL's Avatar
 
Join Date: Apr 2009
Location: Northern Alabama
Posts: 7,320
2000 XE V6 Xterra
RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all
Garage
Did you re-set the base timing after installing the new distributor?

-Kelly- Build Thread

Then he showed those men of will what will really was. - Verbal Kint
RacerXXL is offline  
2000 XE V6 Xterra
#3 Old 01-02-2013, 06:53 PM
estarguars
Member
 
Join Date: Jan 2013
Posts: 10
200 Xterra
estarguars is on a distinguished road
Ill ask my friend (who installed). I am not a mechanic and I appreciate the response. I will update soon. Any other thoughts and tips are welcomed.
estarguars is offline  
200 Xterra
#4 Old 01-07-2013, 03:22 PM
estarguars
Member
 
Join Date: Jan 2013
Posts: 10
200 Xterra
estarguars is on a distinguished road
Distributor was off by 2 teeth, car ran like new for 2 days after adjustment.

Car is now back in the shop because initial symptoms came back before stalling. Now its jerking, misfiring (I think) and occasionally stalling.

estarguars is offline  
200 Xterra
#5 Old 01-08-2013, 08:53 AM
kms1990
Addict
 
kms1990's Avatar
 
Join Date: Jul 2012
Location: benbrook tx
Posts: 643
2000 Xterra
kms1990 is on a distinguished road
do you know if he set the rotor back to the same postion the old one(thing under cap in old distributor) came off at? that could cause issues as well and which plugs did you get? what brand and double platinum platinum or copper or iridiums? our tuck will run best on ngk double plats or irdiums

MY BRIGHT AZZ LIGHTS!

MY STEREO BEATS EM ALL!
My Laundry List
LIFT()
MUD TIRES()
DROP IN K&N FILTER(X)
UPGRADE STEREO(X)
RESTORE BUMPERS(X)
HID AND PIAA FOGS(X)
FIX UP HEADLINER()
WINCH()
MUFFLER UPGRADE()
kms1990 is offline  
2000 Xterra
#6 Old 01-08-2013, 09:10 AM
Itsme
Phreak
 
Itsme's Avatar
 
Join Date: Sep 2010
Location: Oregon
Posts: 3,111
2000 4x4 Xterra
Itsme will become famous soon enough Itsme will become famous soon enough
As for plugs, the NGK iridiums work best.
Have you checked the large intake rubber for cracks, or leaks where hoses and their components come in. If you are getting air leaks after the maf, the idle will suffer and cause stalling at idle.
The older the rubber gets, the more prone it is to crack and leak air. Even a loose connections will cause this problem.

Itsme
2000 X SE

V6 SE 4X4 5spd Build and 00 Silver auto SE 4X4http://www.clubxterra.org/forums/showthread.php?t=26084

Raise TBs (X), paint plastics (X), Replace radiator with one that is bigger and will last (X), install roof lights (X), IAB (X), better tires (X), shackles in rear(X), remove rear sway bar (X), Bilsteins (X)
Itsme is offline  
2000 4x4 Xterra
#7 Old 01-18-2013, 04:43 PM
estarguars
Member
 
Join Date: Jan 2013
Posts: 10
200 Xterra
estarguars is on a distinguished road
The plugs I am using are NGK Laser Platinums

Update: I've been driving the X for about a week with little to no problems (a little jerking). The weather in Colorado has been around 5-15 degrees.

Today the temperature reached 57 degrees and its been jerking/stalling but this time it wont start back up.

Ill have the X towed to the shop and have them check for leaks, cracks and the rotor. What can the heat possibly cause for the X to act up? Ideas?
estarguars is offline  
200 Xterra
#8 Old 01-19-2013, 03:56 PM
Itsme
Phreak
 
Itsme's Avatar
 
Join Date: Sep 2010
Location: Oregon
Posts: 3,111
2000 4x4 Xterra
Itsme will become famous soon enough Itsme will become famous soon enough
The throttle body may be mucked up and need cleaning, to restore good idle characteristics. There also may be an air leak before the TB. Check for cracks and loose hoses going to the intake tube.

Itsme
2000 X SE

V6 SE 4X4 5spd Build and 00 Silver auto SE 4X4http://www.clubxterra.org/forums/showthread.php?t=26084

Raise TBs (X), paint plastics (X), Replace radiator with one that is bigger and will last (X), install roof lights (X), IAB (X), better tires (X), shackles in rear(X), remove rear sway bar (X), Bilsteins (X)
Itsme is offline  
2000 4x4 Xterra
#9 Old 01-19-2013, 11:33 PM
NM2000Xterra
Veteran
 
NM2000Xterra's Avatar
 
Join Date: Oct 2010
Location: New Mexico
Posts: 341
2000 Xterra
NM2000Xterra is on a distinguished road
Check your Maf sensor also...probably could use a cleaning

NM2000Xterra
My favorite mod is my fly rod rack made from duck tape and a hockey stick...
____________________
"That thing looks ridiculous"
"I know, isn't it awesome?!?!"

The Tale of Terra - 2000 XE
More Terra Pics and Such...
NM2000Xterra is offline  
2000 Xterra
#10 Old 01-20-2013, 09:21 PM
kms1990
Addict
 
kms1990's Avatar
 
Join Date: Jul 2012
Location: benbrook tx
Posts: 643
2000 Xterra
kms1990 is on a distinguished road
i agree clean you maf sensor

MY BRIGHT AZZ LIGHTS!

MY STEREO BEATS EM ALL!
My Laundry List
LIFT()
MUD TIRES()
DROP IN K&N FILTER(X)
UPGRADE STEREO(X)
RESTORE BUMPERS(X)
HID AND PIAA FOGS(X)
FIX UP HEADLINER()
WINCH()
MUFFLER UPGRADE()
kms1990 is offline  
2000 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off