Hazard lights not working - Nissan Xterra Forum
 
Thread Tools Display Modes
post #1 of 5 Old 12-25-2012, 06:47 PM Thread Starter
zaxtvnz
Veteran
 
zaxtvnz's Avatar
 
Join Date: Dec 2008
Location: Westfield, IN
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2004 Xterra
zaxtvnz is on a distinguished road
Exclamation Hazard lights not working

Hey Guys! I haven't be around here for a while but still have my 2004 Xterra. She's been running great.

This past August I was driving from Florida to Indiana pulling a trailer when I hit some rain. The turn signal fuse kept blowing and I finally traced the issue to water getting in the trailer wiring connector. I filled it up with some silicone and everything was fixed.

Ever since then my hazard lights haven't worked. The fuse for the hazard system is good and the turn signals work fine. I tested the switch/push button for the hazard lights and it works fine. I'm thinking it may be the relay but I can't find it. I've searched under the steering column and around the pedals but no luck. Can someone tell me where the relay is?

Any other possible solutions besides the relay?

-Zach
BUILD THREAD

2004 Xterra - Black - 4x4 - Automatic
Yakima Loadwarrior
Lobo Rack
Alpine and Rockford Fosgate stereo system
Dash mounted garage door opener mod
Hula Girl Mod
Bridgestone Dueler Revo 2's
zaxtvnz is offline  
2004 Xterra
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-26-2012, 09:55 AM
muadeeb
Banned
 
Join Date: Oct 2011
Location: Dallas, Tx
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2001 Xterra
muadeeb will become famous soon enough
Not 100% certain, but it looks like it's behind the AC controls, near the top center of the dash. It's a blue connector with 3 pins. It wouldn't hurt to double check the grounding locations either. There are two involved here -- 1 by the driver's feet and the other by the front passenger feet, both on the exterior side of the area.
muadeeb is offline  
2001 Xterra
post #3 of 5 Old 12-26-2012, 06:33 PM Thread Starter
zaxtvnz
Veteran
 
zaxtvnz's Avatar
 
Join Date: Dec 2008
Location: Westfield, IN
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2004 Xterra
zaxtvnz is on a distinguished road
Quote:
Originally Posted by muadeeb View Post
Not 100% certain, but it looks like it's behind the AC controls, near the top center of the dash. It's a blue connector with 3 pins. It wouldn't hurt to double check the grounding locations either. There are two involved here -- 1 by the driver's feet and the other by the front passenger feet, both on the exterior side of the area.
Thanks for the help. Mind if I ask where you are getting this info? I see you have a 2001 so I'm wondering if its the same on my 2004. Thanks again.

-Zach
BUILD THREAD

2004 Xterra - Black - 4x4 - Automatic
Yakima Loadwarrior
Lobo Rack
Alpine and Rockford Fosgate stereo system
Dash mounted garage door opener mod
Hula Girl Mod
Bridgestone Dueler Revo 2's
zaxtvnz is offline  
2004 Xterra
post #4 of 5 Old 12-26-2012, 08:57 PM
muadeeb
Banned
 
Join Date: Oct 2011
Location: Dallas, Tx
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2001 Xterra
muadeeb will become famous soon enough
I pulled it from the 2004 FSM, but the 2001 & 04 are very similar as they are both 1st Gens. The major difference between the 00/01 and the 02-04 is the body.
http://www.nicoclub.com/FSM/xterra/2004_Xterra/
muadeeb is offline  
2001 Xterra
post #5 of 5 Old 12-27-2012, 12:29 PM Thread Starter
zaxtvnz
Veteran
 
zaxtvnz's Avatar
 
Join Date: Dec 2008
Location: Westfield, IN
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2004 Xterra
zaxtvnz is on a distinguished road
Thanks for the help. I forgot that I have a copy of the FSM on my computer. I was using the Haynes manual but it isn't as detailed as the FSM.

-Zach
BUILD THREAD

2004 Xterra - Black - 4x4 - Automatic
Yakima Loadwarrior
Lobo Rack
Alpine and Rockford Fosgate stereo system
Dash mounted garage door opener mod
Hula Girl Mod
Bridgestone Dueler Revo 2's
zaxtvnz is offline  
2004 Xterra
Reply

Tags
blinkers , hazards , relay

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off