P300B engine code... - Nissan Xterra Forum
 
Thread Tools Display Modes
#1 Old 11-20-2012, 08:42 AM
Drucifer
Member
 
Drucifer's Avatar
 
Join Date: Dec 2011
Posts: 29
2002 Xterra
Drucifer is on a distinguished road
P300B engine code...

OK. Im running my 2002 with 128k miles on it. I recently lost the timing belt and luckily, got it all bacy together with no internal damage. I was throwing a couple codes (knock sensor, gross evap leak) and resolved them. The knock sensor was handled with a relocation mod and the evap leak was in the canister.
At the same time, I began to get the P300B code for multiple random misfire. Searching the forum here, I found out that the distributor has a bearing issue. So, I replaced that. Timing was set according to instructions with the throttle body sensor unplugged then reconnected. Timing seems to be good. Plug wires were recently (within 1000) miles changed. Plugs were done about 5-6000 miles ago.
On a cold start, I am getting performance issues (i.e. misfiring thats really noticable) until the engine is fully warmed up for about 10 minutes. At 2k on the tach, is where I really seem to notice it. The sound of the RPMs goes up, but the tach starts to drop off. Like I said, this only happens for the first ten or so minutes, then she runs like a top...

Is there any advice out there? Is there a crank re-learn that should have been done after the timing belt? Im getting really frustrated and need some help without having to go to the stealership and donate a kidney to pay for it. Thanks!

Tactical Armor Group Wincher front bumper, KC Daylighters, intake mod, PML with sway away torsion bars, running board delete.

Gotta do the headliner, delete the mud flaps and bedliner the hood, wheels and rocker panels....
Drucifer is offline  
2002 Xterra
Sponsored Links
Advertisement
 
#2 Old 11-20-2012, 01:33 PM
RacerXXL
Administrator
 
RacerXXL's Avatar
 
Join Date: Apr 2009
Location: Northern Alabama
Posts: 7,226
2000 XE V6 Xterra
RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all RacerXXL is a name known to all
Garage
I cant seem to find code P300B in the FSM. Are you sure the code is correct? Normally a proper misfire code will direct you to the cylinder in question but the code you are giving does not show up.

You can do the following to erase stored values in the ECM.

Start engine and bring it up to operating temperature

With he engine running disconnect the MAF sensor plug allowing the engine to run until it dies

Shut off the ignition and re-connect the MAF

Start the engine and allow it to idle for 10 minutes

After that drive as you normally would


Past that start pulling spark plugs and look for problems/incorrect gap. Also check to insure the firing order is correct ie the plugs are going from the correct spot on the engine to the correct spark plugs.

-Kelly- Build Thread

Then he showed those men of will what will really was. - Verbal Kint
RacerXXL is offline  
2000 XE V6 Xterra
#3 Old 11-20-2012, 07:22 PM
cbxterra
Veteran
 
Join Date: Nov 2010
Location: nova scotia, canada
Posts: 409
2000 Xterra
cbxterra is on a distinguished road
maybe you mean P0300. I;ve been trying to figure out the same for awhile. going to try that MAF unplug tomorrow. try looking at the sticky for the factory service manuals in the repair section, they have a list to follow to solve the variuos codes
cbxterra is offline  
2000 Xterra
#4 Old 11-20-2012, 08:45 PM
ShiftingSkys
Phreak
 
ShiftingSkys's Avatar
 
Join Date: Aug 2010
Location: Raleigh
Posts: 1,751
2002 Xterra
ShiftingSkys will become famous soon enough
In this situation I honestly think that the knock sensor was not bad this time and Was actually trying to tell you you had a problem... Rare I know.

Check all wiring and connectors that lead to the cylinders is what Id say first but you got that covered. Spark Plugs and wires. Now you said you did those so Check

I would suggest distributor cap and rotor second but I believe since you replaced the WHOLE distributor then those should be NEW right? so Check.

The next step is the VALVES or an intake leak. Check to see if the camshaft sensors doing what its supposed to and reading right or a vacuum line is unhooked.

If that is correct I would bet my bottom dollar on the O2 sensors. I would move onto 02 sensors WHY?! Because they are directly in control of Open/Closed Loop on vehicles and with what you stated in CLOSED loop the vehicle runs good. But for some reason in open loop runs like shit. Maybe you damaged an O2 or it got wet or oil fouled.

The last Thing I would say is check to see if the catalytic converter has gone bad so smell the exhaust and see if it smells like rotten eggs in the exhaust.

In rare cases I am sure faulty fuel injectors or computer(which controls the injectors) could be bad with this code in rare cases.

GL But id bet my bottom dollar on O2 simply because you said after 10 minutes the ride smoothes out.

2002 Nissan Xterra

Lifted and Ready to Roll!

Build Thread-http://www.clubxterra.org/forums/showthread.php?t=38877

Last edited by ShiftingSkys; 11-21-2012 at 09:27 AM.
ShiftingSkys is offline  
2002 Xterra
#5 Old 11-23-2012, 03:21 AM
Drucifer
Member
 
Drucifer's Avatar
 
Join Date: Dec 2011
Posts: 29
2002 Xterra
Drucifer is on a distinguished road
I'm leaning toward a plugged / collapsed catalytic at this point... Lots of noise (exhaust) underbrush driver floorboard, NO power under load...

Back to the mechanic on Tuesday.

Tactical Armor Group Wincher front bumper, KC Daylighters, intake mod, PML with sway away torsion bars, running board delete.

Gotta do the headliner, delete the mud flaps and bedliner the hood, wheels and rocker panels....
Drucifer is offline  
2002 Xterra
#6 Old 11-25-2012, 02:06 PM
Drucifer
Member
 
Drucifer's Avatar
 
Join Date: Dec 2011
Posts: 29
2002 Xterra
Drucifer is on a distinguished road
If a fellow was to punch out the catalytic innards, (theoreticly, of course) would it throw a code? NY is a catalytic mandatory state and I would never think about breaking the law, but just wondering if it would show up on the scan for the inspection.

Worst case, I guess I'll have to replace the catalytic, but I'm hoping I can resolve this on the cheap...

Tactical Armor Group Wincher front bumper, KC Daylighters, intake mod, PML with sway away torsion bars, running board delete.

Gotta do the headliner, delete the mud flaps and bedliner the hood, wheels and rocker panels....
Drucifer is offline  
2002 Xterra
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off