Installing aftermarket stereo in 05 xterra with Rockford fosgate need help... - Nissan Xterra Forum
 
Thread Tools Display Modes
post #1 of 5 Old 11-09-2012, 05:54 PM Thread Starter
ashock07
Noob
 
ashock07's Avatar
 
Join Date: Nov 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2005 Xterra
ashock07 is on a distinguished road
Installing aftermarket stereo in 05 xterra with Rockford fosgate need help...

Hi guys I'm about to lose my mind I bought the wiring harness 70-7551 and connected it how it explains and still cant get power to the head unit someone please help me!!! Am I missing something?
ashock07 is offline  
2005 Xterra
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-09-2012, 09:00 PM
BakerX05
Seasoned
 
BakerX05's Avatar
 
Join Date: Mar 2010
Location: Oregon City, OR
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2005 Xterra
BakerX05 is on a distinguished road
This might help.

http://www.thenewx.org/forum/showthr...lugs+head+unit

Baker
'05 Granite SE 4x4|AJ SS Rock Slider|PRG 3" suspension lift|285/75r16 Yokohama Geolander MT+|Pro Comp 7089-6868|PIAA 520 ATP|Shrock rear bumper w/tire carrier|NXrocks Skids|IMS|Flip Kit| Baker's X
BakerX05 is offline  
2005 Xterra
post #3 of 5 Old 11-10-2012, 09:21 AM Thread Starter
ashock07
Noob
 
ashock07's Avatar
 
Join Date: Nov 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2005 Xterra
ashock07 is on a distinguished road
Figured it out plug the antenna in before seeing if it works.
ashock07 is offline  
2005 Xterra
post #4 of 5 Old 12-12-2012, 07:24 PM
Delirious
Member
 
Join Date: Nov 2012
Location: owen sound ontario canada
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 Xterra
Delirious is on a distinguished road
Quote:
Originally Posted by ashock07 View Post
Figured it out plug the antenna in before seeing if it works.
if it only works with the antenna plugged in, you still need a ground wire. in most nissans they dont ground through the harness but through the chassis mount.

Last edited by Delirious; 12-12-2012 at 07:24 PM. Reason: really freaking bad spelling mistake
Delirious is offline  
2003 Xterra
post #5 of 5 Old 02-05-2014, 05:21 PM
Jon70ProofZ
Noob
 
Join Date: Jan 2014
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Jon70ProofZ is on a distinguished road
how many of the four factory plugs do you use when wiring an aftermarket deck?
or can anyone tell me what each of these plugs are? i know two are for the radio and one is for the steering controls
Jon70ProofZ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off