Trailer Wiring Problems - Nissan Xterra Forum
 
Thread Tools Display Modes
#1 Old 04-17-2012, 12:08 PM
Michael_Hill
Noob
 
Join Date: Dec 2010
Posts: 6
2011 Xterra
Michael_Hill is on a distinguished road
Trailer Wiring Problems

2011 Xterra Pro-4x with the Nevada Tow Package

After four months no problems with my Cargo Trailer hooked up I started having light issues. I had to redo the trailer side connections and only got some working. As a bypass I bought a set of magnet lights because I need to get the trailer to recoat my hot air balloon this week.

I plugged the lights in and I get no flasher function on the lights but OK on the truck. The flashers were fine before the problems with the trailer. Is there a particular fuse I should look for? Should I just go drop another $30 on the factory plugin harness? Will that fix it?
Michael_Hill is offline  
2011 Xterra
Sponsored Links
Advertisement
 
#2 Old 04-20-2012, 09:34 PM
Arkybill
Noob
 
Join Date: Sep 2011
Location: Conway, Arkansas
Posts: 3
2011 Xterra
Arkybill is on a distinguished road
There is at least 2, maybe 3 fuses that can be blown. Sorry, I don't have the factory manual handy. I went thru this issue myself with a 11 pro4x. I found the problem in the bottom fuse box. Just going on memory here, look at the diagrams in each fuse box, and check the fuses.
Arkybill is offline  
2011 Xterra
#3 Old 04-21-2012, 10:55 PM
Fzzt
Moderator
 
Fzzt's Avatar
 
Join Date: Jul 2008
Location: Puyallup, WA
Posts: 3,567
2009 OR Xterra
Fzzt has a spectacular aura about them Fzzt has a spectacular aura about them
Absolutely get the factory plug in harness! When I added a hitch to mine that's what I did and haven't had any problems with trailer lights. It's really plug & play, no splicing at all.

Traded in all my project cars for a new Xterra, not an ounce of buyers remorse. My build thread
Fzzt is offline  
2009 OR Xterra
#4 Old 04-24-2012, 03:27 PM
ducatidom
Noob
 
Join Date: Aug 2011
Posts: 5
ducatidom is on a distinguished road
You need the relays in the passenger kick panel if you don't have them already. Without them a 4pin connector will work, but will keep blowing fuses.
ducatidom is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Xterra Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off