xterra engine codes [Archive] - Nissan Xterra Forum

: xterra engine codes


Ricer-X
08-23-2007, 10:31 AM
these are for the 3.3l

FRONTIER & XTERRA 3.3L
P0000
No Self Diagnostic Failure Indicated
P0100
MAF Sensor
P0105
Absolute Pressure Sensor
P0110
IAT Sensor
P0115
ECT Sensor
P0120
TP Sensor
P0125
ECT Sensor
P0130–P0134
Front HO2S RH Bank
P0135
Front HO2S Heater RH Bank
P0136–P0140
Rear HO2S RH Bank
P0141
Rear HO2S Heater RH Bank
P0150–P0154
Front HO2S LH Bank
P0155
Front HO2S Heater LH Bank
P0157–P0161
Rear HO2S LH Bank
P0171
Fuel Injection System Lean RH Bank
P0172
Fuel Injection System Rich RH Bank
P0174
Fuel Injection System Lean LH Bank
P0175
Fuel Injection System Rich LH Bank
P0180
Tank Fuel Temperature Sensor
P0217
Engine Over Temp
P0300
Multiple Cylinder Misfire
P0301–P0306
Misfire Cylinders 1–6
P0325
Knock Sensor
P0335
CKP Sensor
P0340
CMP Sensor
P0400
EGR Function
P0402
EGRC-BPT Valve Function
P0420
TWC Function
P0430
TWC Function
P0440
EVAP System Small Leak
P0443
EVAP Canister Purge Control Valve & Solenoid Valve
P0446
EVAP Canister Vent Control
P0450
EVAP System Pressure Sensor
P0500
VSS
P0505
IAC-AAC Valve
P0510
CTP Switch
P0600
A/T Control & Communication Line
P0705
Park Neutral Position Switch/Circuit
P0710
ATF Temp Sensor/Circuit
P0720
Vehicle Speed Sensor/Circuit
P0725
Engine Speed Signal
P0731
A/T 1ST Gear Function
P0732
A/T 2ND Gear Function
P0733
A/T 3RD Gear Function
P0734
A/T 4TH Gear Function
P0740
TCC Solenoid/Circuit
P0744
A/T TCC Switch/Valve Function
P0745
Low Pressure Solenoid/Circuit
P0750
Shift Solenoid A/Circuit
P0755
Shift Solenoid B/Circuit
P1105
MAP/BARO Switch Solenoid Valve
P1148
Closed Loop B1
P1168
Closed Loop B2
P1320
Ignition Signal
P1336
CKP Sensor
P1400
EGR Valve & EVAP Canister Purge Control Solenoid Valve
P1401
EGR Temperature Sensor
P1402
EGR System
P1440
EVAP System Small Leak
P1444
Purge Volume Control Valve
P1446
EVAP Canister Vent Control Valve
P1447
EVAP System Purge Flow Monitoring
P1448
Vacuum Cut Valve
P1490
Vacuum Cut Valve Bypass Valve
P1491
Vacuum Cut Valve Bypass Valve
P1605
A/T Diagnosis Communication Line
P1705
Throttle Position Sensor/Circuit A/T
P1706
PNP Switch/Circuit
P1760
Over/Run Clutch Solenoid/Circuit

additional resources courtesy of NateDawgG

http://www.obd-codes.com/trouble_codes/

Anthony
08-23-2007, 10:33 AM
Nice Post. I stickied it for ya.

Ricer-X
08-23-2007, 04:14 PM
ILL GET THE KA24 ONES TOMORROW AND ADD THEM TO MY POST ABOVE
appreciate the sticky anthony

Ricer-X
08-23-2007, 04:19 PM
FRONTIER & XTERRA 2.4L
P0000
No Self Diagnostic Failure Indicated
P0100
MAF Sensor
P0105
Absolute Pressure Sensor
P0110
IAT Sensor
P0115
ECT Sensor
P0120
TP Sensor
P0125
ECT Sensor
P0130P0134
Front HO2S
P0135
Front HO2S Heater
P0137P0140
Rear HO2S
P0141
Rear HO2S Heater
P0171
Fuel Injection System Lean
P0172
Fuel Injection System Rich
P0180
Tank Fuel Temperature Sensor
P0300
Multiple Cylinder Misfire
P0301P0304
Misfire, Cylinders 14
P0325
Knock Sensor
P0335
CKP Sensor
P0340
CMP Sensor, Detectable & Non-Detectable Circuit
P0400
EGR Function
P0402
EGRC-BPT Valve
P0420
TWC Function
P0440
EVAP System Small Leak
P0443
EVAP Canister Purge Volume Control Solenoid Valve
P0446
EVAP Canister Vent Control Valve Circuit
P0450
EVAP Control System Pressure Sensor
P0500
VSS
P0505
IAC-AAC Valve
P0510
CTP
P0605
ECM/ECCS Module
P1105
MAP/BARO Switch Solenoid Valve
P1148
Closed Loop Control
P1320
Ignition Signal
P1336
CKP
P1400
EGR & Canister Control Solenoid Valve
P1401
EGR Temperature Sensor
P1402
EGR System
P1440
EVAP System Small Leak
P1444
Purge Volume Control Valve
P1446
Vacuum Cut Valve
P1447
EVAP Purge Flow Monitor
P1448
Vacuum Cut Valve
P1490
Vacuum Cut/Bypass Valve
P1491
Vacuum Cut Valve Bypass Valve
P1706
Park/Neutral Position Switch
P1775
TCC Solenoid Valve Circuit
P1776
TCC Clutch Solenoid Valve

terry345
06-09-2008, 07:53 PM
how about the flash codes.

P0301 = 0608 on light flash when activating pcm with key on and turn screw clockwise 2 seconds then back.

Does anyone have all of the flash codes?

json3904
06-09-2008, 08:36 PM
terry345 what do you mean "flash codes"?????

terry345
06-10-2008, 02:16 PM
The flash codes are obtained when you turn you key on, then you use a small screwdriver to turn the mode selector on the PCM to cw and leave for 2 seconds, then ccw back to normal position.
The check engine light will flash the codes, for example, 6 slow flashes followed by 8 fast flashes = 0608 which converts to P0301.

My Haynes manual only lists the flash codes and their P conversion on faults that will turn on the check engine light.

Now the flash codes are not exact as I found out today when visiting my Auto Zone store.
They found P0325 and P1336.
P1336 Crankshaft position sensor is about $12.00
P0325 Knock Sensor is over $ 100.00 and harder to get to.
It's under the Intake Manifold.
The Crankshaft position sensor is not too hard to get to on this small V-6.


Can either of these sensor faults cause the engine to lope?

Thanks,

Ricer-X
06-10-2008, 02:31 PM
if your xterra isnt supercharged then the knock sensor is not somehting you need to worry about, if you replace it you will have the same code a few months later
90% of us 1st gen N/A v6 guys have it, ive had that code for about 2yrs now

json3904
06-10-2008, 03:20 PM
i as well have the Knock sensor, and as to the Crankshaft position sensor that might be the reason but im not sure....

coloradox
06-16-2008, 08:31 PM
well i have acode po 430 catalyst below threshold bank 2 is that a o 2 sens or a cat

CanX
08-31-2008, 04:55 PM
FYI:

PO420/430 are O2 sensors.

430 is for the side with the #1 cylinder, 420 for the other side.

I'm getting 430 for my header install and trying to work out a solution.

jeddedly
09-03-2008, 10:51 PM
if your xterra isnt supercharged then the knock sensor is not somehting you need to worry about, if you replace it you will have the same code a few months later
90% of us 1st gen N/A v6 guys have it, ive had that code for about 2yrs now

What about if you do have the supercharged engine?? Ive had that code since I bought it but the dealer told me it was a phantom code? What effect would it have? My engine runs rough at idle and is way past bad in mileage. talking 400ks per tank at the most. And Im pretty easy on the pedal. Any ideas anyone??

json3904
09-03-2008, 10:55 PM
if you have the KS and you have a SC then the sup is being shutdown due to the code.... they need to change it outso it runs right... tell then that it is a phantom code for the non supe models.....

jeddedly
09-04-2008, 05:11 PM
would that have been under warranty??

json3904
09-04-2008, 05:49 PM
depends on what warranty you have.... either way if they sold it to you with that code they should fix it free of charge....

jeddedly
09-04-2008, 08:43 PM
I wish I had some faith that they would. Ill have to call Nissan and give it a shot.

munkman
10-03-2008, 01:15 PM
These codes that you guys are referring to, where do they show up on your Xterra? You can guess from my question that I've been lucky enough not to have any major issues, but I also haven't started modding... yet
:cool-big:

Ricer-X
10-03-2008, 01:33 PM
when your check engine light comes on, you go to autozone and have them scan the code

or if you have your own scanning tools you can scan it yourself, i own a scanguageII which scans engine codes

munkman
10-03-2008, 02:33 PM
Ahhhh *light goes on* no pun intended lol

Does autozone charge for that service?

json3904
10-03-2008, 02:50 PM
no it is one of the services that they dont charge for... just like they test your alt, starter, battery for free as well....

coloradox
11-16-2008, 10:48 PM
what the h is twc

darkfire5000
01-05-2009, 08:53 PM
I have code P1163 and P0328 and they keep coming back any ideas on what could be the problem?

darkfire5000
01-07-2009, 05:16 PM
Would be greatly appreciated with figuring out what those codes for my 2003
3.3L Exterra would mean???

Richiesson
02-21-2009, 06:37 PM
Hi, interesting these flash codes, where is the pcm? I would like to try this. 2006 4.0LThanks

LA RANA
02-21-2009, 08:36 PM
want the same list for 2nd gens...where can that be found?

dezurtrat
02-21-2009, 08:41 PM
want the same list for 2nd gens...where can that be found?


I'll start a list as soon as I get a chance.

LA RANA
02-22-2009, 04:14 AM
I'll start a list as soon as I get a chance.

That would be awesome of you, thanks!! :)

Xterra Mike
03-05-2009, 02:36 AM
Hey guys, i was just searching through my fav's in my drop down list on IE and i came across this. I have no clue where i got it but i know its very inportant info. Can't believe i've had this all this time and didn't know it. Maybe you Admin's can do something with this to make it easy to find. Well here ya go.
http://www.nissanhelp.com/diy/obd_codes/nissan_engine_codes_chart_3.htm

json3904
03-05-2009, 07:44 AM
it is now a sticky

Xterra Mike
03-05-2009, 07:32 PM
cool

toothpick745
04-29-2009, 09:37 AM
what do these codes do? can i use them to make my X better (faster, more fuel efficient)?

Xterra Mike
04-29-2009, 05:01 PM
When your SES (service engine soon) light goes on you get it scanned from an autopart store and a number will come up. Write that number down and check it out here for your problem.

toothpick745
04-30-2009, 09:33 AM
oh ok. thats it?

buckethead47
04-30-2009, 10:11 AM
thats good info mike! with the thread being sticky we should also change the title of the post to engine codes ore something.

andrew555
08-05-2009, 09:42 AM
i have a 2002 nissan xterra and i have a dent on the bottom of my rear bumper or the right side do i have to take my whole bumper off or does the sides come of and does anyone know how to do that

RawkerStatus
08-05-2009, 11:02 AM
i have a 2002 nissan xterra and i have a dent on the bottom of my rear bumper or the right side do i have to take my whole bumper off or does the sides come of and does anyone know how to do that

dont hijack some1s thread. you need to make a new one.

btw thanx mike. hopefully i'll never have to use this.

Boogie
08-24-2009, 10:33 PM
Awesome find! Is this a list of codes that Nissan's share universally? Or is this specific to the Xterra?

Xterra Mike
08-25-2009, 04:17 AM
Awesome find! Is this a list of codes that Nissan's share universally? Or is this specific to the Xterra?

As far as i understand the codes are universal. Mandated by the government.

Ricer-X
08-31-2009, 03:05 PM
what does this one mean?

P0430
TWC Function

OdiN
08-31-2009, 03:18 PM
P0430 OBD-II Trouble Code
Technical Description

Catalyst System Efficiency Below Threshold (Bank 2)
What does that mean?

Basically this means that the oxygen sensor downstream of the catalytic converter on bank 2 is detecting that the converter is not working as efficiently as it should be (according to specs). It is part of the vehicle emissions system.

Page copy protected against web site content infringement by Copyscape
Symptoms

You will likely not notice any drivability problems, although there may be symptoms such as a rough/hard idle when cold.
Causes

A code P0430 may mean that one or more of the following has happened:

* The catalytic converter is no longer functioning properly
* An oxygen sensor is not reading (functioning) properly
* There is an exhaust leak


I think TWC is Three Way Catalyst.

Ricer-X
08-31-2009, 04:21 PM
ah, so, its either the cat, the o2, or a leak

and it IS recurring
sigh

Alpha
09-04-2009, 01:12 PM
I have had the P0420 since the first time I went off roading.

I was thinking of just getting an exhaust, eliminating the second cats and putting new O2 sensors, would this fix it?

My truck is a little rough at idle, even when its warmed up.

Cyclemut
10-13-2009, 12:03 AM
I've cleaned up this thread due to it being sticky. If this continues, I'll move the relative information to a new thread. Let's keep it clean gentlemen.

And yes, most of the codes are universal. There are some codes that are specific but are mostly universal and easily adaptable to other vehicles (the OBD-II code system was mandated to be that way by the feds, Xterra Mike was on the money!).

xxyournoonexx
10-13-2009, 12:04 AM
Most of the new readers tell you was they scan it. The smaller, cheaper ones just give out a code.

Sam Peterson
10-21-2009, 08:02 AM
My check engine light is on and the code says the knock sensor has went bad. I am wondering how to get to the sensor, is it under the heads. my veh. is a 2003, v6

Ricer-X
11-14-2009, 08:57 AM
its under the intake manifold, the common advice is that if you dont have a supercharge x its not a problem, but there is no reason you cant relocate it if you want, some say it helps with mpg's
ive had the knock sensor code for almost 4 years now

cskipgo
12-26-2009, 07:02 PM
Hi Guys.
I have tried doing a search and unless I did it wrong I can't find answers.

My 2008 Xterra 2WD has an error code of P0443. Is this common? I read a note on a google seqarch saying there as been some errors in this code?

Any help would be appreciated! Thanks!

allv5
03-01-2010, 04:44 PM
I am getting an error message P0505 IAC-AAC Valve when testing my Exterra, can someone help what can I do, where is my valve located can I clean it? Thanks.

Lopez80
03-29-2010, 11:49 PM
The shop checked my 05 xterra se for a code and found a 1731 code..i think it has to do with the automatic transmission? I need some help from the forum..i just got this Xterra and already replaced the radiator because the tranny fluid leaked into the coolant..flushed the tranny and now the overdrive acted up twice ..the tranny fluid looks good and nothing else is wrong please help???

Cyclemut
03-30-2010, 12:16 AM
Anyone having issues are encouraged to start a new thread with their concerns. This is a sticky thread for the codes. A full on discussion will be moved and this thread cleaned up, again. Tomorrow morning the posts asking for advice will be removed.

bowlerx
06-30-2010, 10:57 PM
what is twc function?

RedRover
07-01-2010, 01:21 AM
what is twc function?

That's a P0420 code and means your Three way catalyst is bad or has a fouled 02 sensor on it.

bowlerx
07-01-2010, 09:50 PM
ok cause i have a cracked exhaust manifold on the pass. side. thats probably throwing the o2 sensor out of whack.

RedRover
07-01-2010, 09:52 PM
yup that's it. Happens to about all of us. I have a cracked driver side just havent had money to replace it. would like to get headers but that's even more money....: (

bowlerx
07-03-2010, 09:38 AM
true

NateDawgG
07-12-2010, 09:13 AM
Just threw error PO1446 - clogged EVAP. What to do? Hmmmmmmmmmmm....

Ricer-X
07-12-2010, 12:45 PM
first post updated with a new link

NateDawgG
07-12-2010, 01:21 PM
Word up.

kizzolie
07-21-2010, 03:09 PM
so knock sensor on a non supercharged engine is fine?

kizzolie
07-21-2010, 03:11 PM
so knock sensor on a non supercharged engine is fine?

p.s. these are my codes.

http://i14.photobucket.com/albums/a331/kylebarden/49429587.jpg

any ideas my friends?

ispymab
09-17-2010, 08:36 AM
I need help with a PO345 code. I know it is a cmp sensor bank 2

THEIRONBULL
11-15-2010, 03:28 PM
Hi everyone. I was driving home last night when the Service engine Soon light came one. It was solid and was not blinking. I baby my Xterra....Like really take care of it. its a 2005 with 50000 km on it. The last thing I did was clean my AEM air filter on it. I was told by the dealership that cause it was a solid light that it isn't too serrious. I hope and pray I'm going to have to pay a crazy repair bill.

Any thoughts out there?

Thanks!

Steve from Calgary

Cyclemut
11-15-2010, 03:46 PM
Yep, since you cleaned your aftermarket air filter, did you oil it? If so, you need to clean off your MAF sensor and clear the light. Also, use less oil on your filter because it's taking out your MAF. If cleaning it doesn't fix it, you're gonna drop some dollars to get it fixed.

It might also help to start your own thread in the future with your problems instead of tagging onto an existing one. Makes it easier to be responded to with specifics to you and not everything else. ;)

THEIRONBULL
11-15-2010, 03:55 PM
oh my bad man! I'm kinda new to this whole forum thing. And no my AEM brute force air filter doesnt need oiling. Infact it says in bold lettering at the end of the filter not to oil it. It was a little damp when I re-installed it. But the light came on the next day after I put it back on.

Can you also please tell me how to start a new thread?

thanks!

Cyclemut
11-15-2010, 04:18 PM
Go to the proper section (go to the top of the page and hit the Forum button, 2nd from the left in the red area) and you'll see a listing off all the different sections. Pick the section that closely resembles your issue and click on it. At the top of the page, you'll see a New Thread button, click on it and start up a conversation!

In the General section, you'll see a New Member Introduction area. It's a great place to start a new thread on yourself, tell us a little about yourself, maybe post up some pics of your ride and meet some of the folks here.

If your filter doesn't take oil, but the light came on after you installed it, double check that none of the clamps are loose and that the intake boot after the filter housing is on correctly (and all the way) and that there are no air leaks after the filter house between it and the engine.

CTTRP
02-25-2011, 09:02 PM
After a timing belt tensioner replacement, (it was squealing), I got a P0300 code. After dicking around replacing plugs, wires, rotor and cap, checking for air leaks and checking the CKPS signal, I decided to go back in and check the valve timing. lo and behold, the right cam sprocket was off 1 tooth. Reset the valve timing and made sure to crank it thru 2 turns and check it. Voila just like magic, the SES went off and the rough idle went away. Note to self.... double and if necessary, triple check the valve timing before closing it back up and make sure you crank it thru just to be sure! What a pain in the A**. All good now though.

cajun jamie
02-28-2011, 05:54 PM
p.s. these are my codes.

http://i14.photobucket.com/albums/a331/kylebarden/49429587.jpg

any ideas my friends?

I just had my codes read and had almost an identical pair of codes, except small leak detected. I wonder why these come in pairs?

soccerbrace
02-28-2011, 07:15 PM
They do not come in pairs Cajun jamie. Everyone has that ks, and you probably had that knock sensor code 3 years ago. You are just seeing it now because you saw your check engine light come on. The knock sensor will NOT illuminate your check engine light. The small evap leak will however. That is what turned it on, and that is why you scanned it in the first place. Now with a scanner, that knock sensor will absolutely show up as a code. Make sure your gas cap is clicking 3 times before driving off.

Xtara75
03-03-2011, 04:57 PM
Auto zone tells me it is the "AF sensor rich shift detected" and the cause is failed AF sensor or fuel injector or pressure related fault.
Any ideas anyone?? What exactly needs to be replaced? Price for the part?

osprey
05-23-2011, 11:44 AM
whats code po154 ../

TKDX00
05-23-2011, 12:49 PM
whats code po154 ../

scan down the first page of this thread... O2 sensor I think

thisistruth
06-21-2011, 07:00 AM
hey everyone. I'm new to the xterra world, just got my first one a few weeks ago and I love it already! but i do have a CEL on and 6 codes to deal with now. i have a feeling it's an electrical issue but would like to get your 2 cents on it. here are the codes:

P0132
P0138
P0152
P0158
P0328
P0328(this showed up twice for some reason)

i did some research on these and looked at the engine codes page and saw that they are a voltage issue in my RH and LH O2 circuits front and rear sensors(0132, 0138, 0152, 0158). the P0328 is a knock sensor issue that I assume is caused by the engine running "off" due to O2 sensor issues. the reason I think this could be an elec problem is i have a 4 channel amp with aftermarket speakers (no sub) that the amp recently blew a fuse (seems to be the internal amp fuse, have yet to confirm this). one thing that is strange is the amp stopped working about a week and a half after the CEL came on, so they could be unrelated issues. but I have a feeling there's something weird in the elec. but anyway, does anyone have any ideas about this and if so a possible solution? I'm pretty good at doing work myself and can handle most projects but I just don't know where to start.....another reason i think this is elec is i doubt both o2 sensors would go bad at the same time....but i do need to get this fixed as i dont want to drive it for long with a "knock" going on. trying to avoid going to a shop but will if i have to. thanks for the help!

thisistruth
06-21-2011, 07:09 AM
sorry guys, i'll start a new thread for this ^^^

Carlos PR
06-28-2011, 06:24 PM
i have the p1605 code how can i repair it?

JimN
07-13-2011, 12:11 AM
I have read Dadster's post in which he describes how to obtain SES codes for the Altima

In car ECM Diagnostics/ECM Reset procedure:

Is there a process like this for the 2000 Xterra or do I HAVE to go somewhere to have the codes pulled.

Thanx,
Jim


Also, I do have one little tid-bit of info regarding the Knock Sensor codes (P0325) I have noticed that a few replies indicate that if you do not have supercharge then it does not matter. NO SO. Well at least in NJ. In the state of NJ if the code P0325 shows up at an Motor Vehicle Inspection Center, your car will FAIL. I have argued this with the state as far as to go to the Chief of MVI and, of course, I have lost every argument.


2000 Xterra Green Metallic
3.3L V6
4WD XE
Completely stock except for Stereo system.

soccerbrace
07-13-2011, 12:46 AM
I have read Dadster's post in which he describes how to obtain SES codes for the Altima

In car ECM Diagnostics/ECM Reset procedure:

Is there a process like this for the 2000 Xterra or do I HAVE to go somewhere to have the codes pulled.

Thanx,
Jim


Also, I do have one little tid-bit of info regarding the Knock Sensor codes (P0325) I have noticed that a few replies indicate that if you do not have supercharge then it does not matter. NO SO. Well at least in NJ. In the state of NJ if the code P0325 shows up at an Motor Vehicle Inspection Center, your car will FAIL. I have argued this with the state as far as to go to the Chief of MVI and, of course, I have lost every argument.


2000 Xterra Green Metallic
3.3L V6
4WD XE
Completely stock except for Stereo system.

Um, we never said that it is OK with your state. We said that it will not affect performance.

JimN
07-13-2011, 12:53 AM
Sorry. My mistake. I must have misinterpreted.

NJDMV argues that it is a "vital" part of your vehicles emissions. Therefore, we cannot give you a passing grade. HUH?

aerosmith8098
08-07-2011, 07:56 PM
I am going to be changing out my catalytic converter next weekend, the code is showing bank 2. If i'm looking at it from underneath, which side is bank 2, passenger or driver's side? Feedback greatly appreciated. Thanks :)

l90096616
08-15-2011, 02:46 AM
I got p0455 P1448 P0326 do i need to get it fix?i own a 02 xterra 3.3L 4wd without supercharger

Rebel Lady
12-08-2011, 05:21 PM
I went to AutoZone for diagnostic test and got P0744 (Torque Convertor CKTT Intermitted). What I need fix it? I have 2001 3.3L 4X4..
Do Transmission or Convertor will turn to bad or lock up?
Where is the solenoid?

billywabbit
01-30-2012, 09:51 PM
Has anyone run into this problem....codes:P0500, P1212, U1001. Problem starts with the VSS dropping out, then others cascade from there. Battery, ECM, Comm Bus...?
When the xterra is warm, I rock the tranny from R to D then D to R several times (6-7) shut key off then restart and problem goes away until it cools down again....help?

serch64
02-29-2012, 07:55 AM
Hi, everyone I'am brand new today here and I need your help. I need to change the rotors and pads for my Xterra 2001 4x4 but I don't know the especifications to put back all the bolts, the pressure required, any help please>

GollyGreen
05-15-2012, 09:50 AM
Is there a way to clear the codes
to see if my repairs worked or not?

lharz519
06-07-2012, 09:14 AM
Hi everyone just wondering if anyone had encounter these problem and if any one has a suggestion or fix to these problem? Here's what happened:

- My 06 xterra check engine light came on with a code 0446/0447 i think but anyway, the obd II scanner indicates "EVAP VENT VALVE OPEN/SHORTED"

- So I checked my Solenoid Vent Valve with 9V battery and it's clicking so I guessed it is still good but it end up replacing it with new one just to make it sure.

- I put the new one on and cleared the code but, after couple of days the SES code went on again and it's the same code again. So, I pulled out the solenoid switch and test it with 9v battery and it's clicking so i assumed it is good.

- Finally I checked the connector or harness and turn on the key to check if there is voltage or current with my multimeter tester from the ECU/ECM but
there is no current, so I did the continuity test of the wire from the harnness goes to ECU connector to make sure if the harness is broke. But the my Multimeter tester indicates it has a good continuity.

_ So, my question is:

Is there any possiblities that my ECU/ECM is faulty or Is there anything I can do to fix the problem??? Any suggestions??? THANK YOU in ADVANCE.. Have a great day to everyone.

mproctor90
12-21-2013, 10:23 PM
so i have a fuel tank temp sensor code. i think it was a p0130. what issues can this cause?

mproctor90
12-21-2013, 10:25 PM
oops my bad its a p0180 code being thrown for the fuel tank temp sensor.

billywabbit
03-08-2014, 03:51 PM
I found after the dealer could not resolve my issue was that it ended up being the control module for the antilock brakes!!!!

mrwoodboat
09-17-2014, 07:10 PM
Hi All '04 Xterra with 103K. We recently changed the spark plugs (NGK) and now we are getting codes 400 and 325 (EGR and knock sensor). Truck runs very smooth and we don't notice a knock.
Any advice? EGR replacement? Coolant was changed about 10k ago, oil is due changing in 2K...

We are getting ready to replace timing belt but want to make sure we address these codes also. Truck is equipped with a Volant cold air system.
thanks

ProjectXo3
10-26-2014, 06:19 PM
Ok so trying to figure out if these codes could be related or have a central cause codes are po328,po732,po152,po158,po335,po400,and po1336 i know wut the mean but they didnt come on till the valve cover gasket was replaced any ideas ? Thanks