rattle comming from somewhere??? [Archive] - Nissan Xterra Forum

: rattle comming from somewhere???


surfnobc2
08-07-2009, 02:25 PM
i have a 06 S 4.0 auto xterra

i can not figure out where this noise is comming from at all .. its a kinda rattle/sounds like a lifter/think its comming from under the hood/yet sounds like a heat shield. haha but the sound only happens when driving. you can put it in netral and rev and you gt no rattle. as well as in drive and hold the break and rev. you get nothing and in reverse the same thing. so i cant figure it out i took it to nissan and nothing they put it on the lift and banged around on everything and no rattles. the onlt thing that bothers me is that the noise excelerates with the car and it does not happen all the time which makes me feel like it is an heat shield or something under the hood. had the tranny checked looked great as well as the engine and its never been off road and it only has 47k on it so still under warranty .. so just tryin to see if anyone has ever heard of this noise or anything close to it ....


i know my writing is a little scrambled sorry

thomas

NateDawgG
08-07-2009, 04:41 PM
I had an obnoxious squeek and had the same problem ferreting it out. What did it was getting a buddy to help me rock it back and forth and up and down while it was parked. After a while we were able to make it squeek and tracked it to the catch mechanism for the hood. A little oil fixed it. So try bouncing it around while parked, see if that helps.

surfnobc2
08-07-2009, 07:27 PM
thanks man that actually a good idea i havent ever messed really inside the hood other than look around but ill try it with it open

Shepherd
08-07-2009, 07:52 PM
I as well have rattle problems, but mine's a first gen, supercharged.

I haven't got to the root of the problem yet, but my noise sounds like the one you're describing.

A sharp metallic rattle noise, that comes and goes while driving, but generally only occurs while accelerating?

I need to inspect/rip-things-apart a little more, but I think mine is caused by the heat shield over the driver-side exhaust manifold.

One of the studs for the shield broke, and I think the noise in my truck is caused by the shield bouncing back and forth in between the engine and the steering column.

I also had another odd rattling noise that was caused by the lower heat shield for my first cat on the driver-side falling off completely. I found it resting on the drive shaft for the front axle, and any time I was in 4x4, the shield was bouncing off the u-joint as the shaft spun.

I will post the results of my next crusade into the bowels of my engine compartment (The quest of the god-aweful rattle).

I don`t know if any of this applies to second gens, but it might help you diagnose your problem.

NateDawgG
08-07-2009, 08:21 PM
I hate these things. Diagnosing random noises sux. My x is at the dealer for a transmission clunk they can't find. Grrrr....

surfnobc2
08-07-2009, 09:25 PM
yea i actually opened the hood after you guys posted and shook the hell out of it but nada... its gotta be some kinda screw shield somthing i hope .. i kinda want it to break so i can get it fixed since its under warranty ..

Shepherd
08-07-2009, 09:36 PM
Maybe wait till your engine is cold then reach on in there and start tweaking the shields.

My truck won`t make the noise from shaking it or driving over a bump either.

I noticed with my heatshield, if I pull it away from the engine quickly, it ticks off the steering column, and when I release it it springs back and ticks off the engine.

Again, once I remove it, I`ll know for sure, and pass on the information, but I would recommend tweaking and poking the heat shields to see if they have enough movement to hit anything nearby.

surfnobc2
08-08-2009, 09:17 AM
ok so heres somthing new today... last night i went to start my car turned the key and whaaalllaa the infomous rattle for about 1 sec. then gone ... everyone that was sitting on the curb outside was like whoathat souonded bad .. i said what did it sound like and they werelike the starter maybe ... so we shut it off and i started it back up again ... annnnnnnnnnnd nothin .. haha ... at all whats soo ever i reved it up ... and nothing ..

but after you guys saying somthingabout the steering colum andthe engine ive been thinking about somthing else .. my steering wheel vibrates a little around 60 mph .. ive had my tires rotated andbalanced 4-5 times and still have alittle vibration .. so maybe there connected who knows that shield maybe vibrating against somthing .. anyways tonight im gunna get under there and pull on some stuff ..


thanks
thom

RIXterra
08-08-2009, 09:21 AM
Try checking your front driveshaft u-joints. they're know to go on the 2nd. gens..

surfnobc2
08-08-2009, 09:54 AM
well if it was the u-joint would it happen in park or when start up .. its a rattle noise .. u-joints make a pop .. especially when you put in drive or reverse ..

surfnobc2
08-09-2009, 11:08 AM
ok so here is the fix i think ..

many of the same people are having the same issue and its pretty well documented ... hopefully this will help a lot of people ..

There is a TSB on all of this .

http://x.nissanhelp.com/forums/Knowledgebase.html?catid=238&sort=d&pp=12&page=4

its the last TSB on the page

you gotta be a member so register ..

its under a pathfinder tsb as well as frontier but not listed for the x ...

lots of great pics on the fix .. only a 30 min job ..

im gunna get mine done here soon ..

thanks for all the help

thomas

surfnobc2
08-12-2009, 07:01 AM
had the minor operation done at nissan yesterday. I know a couple guys up there and they helped me out ... pretty good guys ..

it purs like a kitten when it strats up ... and when around 2200 rpm's

Celts532
08-18-2009, 11:13 AM
Surf, last TSB on the page was about a seat rattle? Which one is it?

surfnobc2
08-23-2009, 12:22 AM
ok i cant find this rattle.. its killing me . that bad thing is i cant make it rattle.. its spontanious ... ahhhhh....i think it might be comming from the skid plate .. i wanna take it off sooo im gunna work on that tomorrow ....

the TSB is ....NTB05-015b.. sorry took so long man .. i did this to my truck and the noise i guess inst comming from there .... soo anyways

if anyone else has any ideas let me know .

kbell2433
08-23-2009, 10:06 AM
I have a 1st gen so im not sure about the second gen, but the heat sheilds that go around the catalitic converters are famous for coming loose... some people tear them compleatly off, but i took a couple of long hose clamps and clamped them tight, problem fixed
:pfeilimkopf-big:

surfnobc2
08-23-2009, 10:34 AM
man i got under there this morning and check i was banging the cat. convert. shield under driver side and and i could make it sorta rattle but thats the only thing that does rattle ive pulled on anything and everything .. heat shield wise .. and damn everything is super tight ... except that one shield on cat. converter...

can you cut those off... because its right next to the transmission .. i wouldnt want it gettin so hot that it would cause wear on the tranny faster.. but if it wouldnt make a dif im gunna cut that bitch off ...

gah im freakin gettin to wear i wanna drive it off a cliff and ride a bike ... damn rattle....

im gunna find it ... :aufkopfhauen-big:

surfnobc2
08-23-2009, 10:55 AM
http://s41.photobucket.com/albums/e251/surfnobc2/?action=view&current=DSCF2320.jpg

http://i41.photobucket.com/albums/e251/surfnobc2/DSCF2320.jpg

BROTHER AND SISTER

waterboy811
09-09-2009, 10:49 AM
Not sure if this will be related to your problem but i had a similar unexplainable noise once. Nothing in neutral but when i would accelerate between certain speeds i would hear a metal on metal vibrating noise. Fearing the worst i took it to the shop and while cleaning stuff out of my X to leave it there (engine off) my mechanic climbed underneath it and mimicked the noise and said is this it? turned out to be a ring support on the exhaust had come loose and was sliding up and down the pipe. when i would accelerate the vibration would cause the ring to vibrate and make the noise. Easy fix and as always a good honest mechanic.

yetiman
12-03-2009, 01:53 AM
Surfnobc2. I have the solution to your noise. Replace the front drive shaft ujoints or just get a new front drive train, only 290. My 05 made a poppoing noise coming to a stop, and a vibrating rattle at 60 mph that was really bad. left out the front drive and went away, replaced joints and was all good.

Meerschweinchen
04-18-2010, 09:08 PM
So I'm a little late here but it doesn't look like there was a definitive answer to this. The random rattling noise occurred on my 2006 Xterra recently (April 2010). I only have 21,000 miles on it and the first time i heard it, I thought it was a little odd because it happened while starting the car and didn't sound like the normal engine start.

It occurred once or twice throughout the week and i wasn't too pleased. Then a few days later while my Xterra was idle, there was a more prominent metal-on-metal "rattle". The sound came from underneath the car. This sound occurred randomly and only a few times while idle (never while driving). I asked my dad to watch the engine just in case I heard wrong but he didn't see anything. I was lying on the ground looking underneath the car.

So what I saw/heard came from a heat shield (i think ... its just a thin curved metal sheet) vibrating against a pipe of some sort underneath the driver side of the car located somewhat in the middle/front of the car. Nothing was loose ... the metal sheet just got too close to the pipe while it was vibrating and hit against each other for about 4-5 seconds before vibrating less intensely [i suppose], then the sound would stop.

This only happened 3-5 times during one week but I haven't heard it for 4 days or so now. I don't think it's anything very serious but if it starts happening more frequently I may start to worry.